February 6th 2019 we get an update in that breaks our installation.

I had seen what packages were installed and I did notice lightdm in there. 

LIGHTDM is one of your major packages – it starts out display or login manager. Other important packages to keep track off is linux and systemd.

IF you did not see the packages that came in you can use our alias RIP in the terminal to see the last packages.

You computer will function fine until you reboot and then lightdm throws you lots of errors.

We have made already a video about the power of TTY here but it can not hurt to make one specifically for this issue.

SOLUTION

Get to a TTY  with  CTRL + ALT + F2 or F3 or … (Virtualbox users use RIGHT CTRL + F2

Login

Choose the prior version with a number

Add lightdm to IgnorePkdg : Y

reboot and have fun again

Other Arch Linux users need to install downgrade with an AUR helper like yay or trizen.

A few hours later the fix comes in

A few hours later lightdm is fixed 

Bug report is here :  https://bugs.archlinux.org/task/61654?project=1&string=lightdm

You have put lightdm in the ignorepkg list in pacman.conf… 

How to update to the latest package now?

Delete the line in /etc/pacman.conf containing lightdm.

Save the file.

Update and install and reboot.